Is there a theoretical maximum polygon count?


I’m using Blender 2.79 and I have a .obj file with a rather high polygon count. It doesn’t show up in Oscistudio AT ALL, which is totally fine. I select the object and decimate the HELL out of it, to the point it’s barely recognizable, but as I reach a low enough poly, it magically appears in Oscistudio. My question is whether or not there’s a theoretical maximum number that oscistudio can handle, and if there are any ways of overcoming it? I don’t need it to be in real time for example. Is there a render mode where I can maintain the high polygon count and use it with oscistudio? Or am I chained to the decimate command?


The Oscistudio blender plugin (where you click “Connect”) has a Max Vertices variable that is probably stopping your object from being sent.

I think the default max vertices is 2000 vertices. If your object exceeds the maximum, it just won’t get sent.

You can increase that variable to allow your object through.

Re: theoretical maximum, I’ve found that at about ~10K vertices, objects starts to become unmanageable and oscistudio starts to crash or lock up. YMMV.

You can get away with more vertices if you’re playing lower frequency notes (i.e. more samples available for each cycle)



Thanks so much for the response, I saw that. I set it to 5,000 and then decimated my model until it was 4,000 and still nothing. Nothing goes through until it crosses a certain threshold. I will try it at lower frequencies as I didn’t realize that had any effect if you were using blender. I thought it was only applicable if you load the .obj file directly.


One other thing I’ve noticed is that if you’re editing an object via modifiers, that sometimes oscistudio doesn’t want to accept the object until you’ve entered then exited the blender object edit mode. I think that oscistudio “sees” that as an object change it should care about.

I’m not sure that the frequency setting affects whether Blender can accept the object.

However, if you have a high-vertex-count object and try to play it at a high frequency, there are not enough audio samples available for all of the vertices. For instance, if you’re at 44.1K audio sample rate and have a 2000 vertex object, you can only play at 22 hz (~A0) before oscistudio has to start dropping samples to display the full object within one audio cycle. It works, but the object corners start getting rounded off and lose detail.

If you still can’t get the connection working, grab some screenshots or a screencap and will try to help.

Good luck!


I got it working thanks so much!! While I can’t get it to work with 5,000 vertices, I DID get it to work with 2,000 and I’m calling it good enough. The tips you gave me were incredibly helpful as I hadn’t made the connection between low frequency and “Time to draw the picture” which makes perfect sense. Thank you!!!