Issue with OsciStudio crashing/closing after clicking "Start!"


OsciStudio Version: (A6.0 client) - Version 1.5
Operating System: Windows x64bit

After finally saving up enough spare cash ($55 CAD) to purchase OsciStudio from a friend, I installed it and tried it both on Blender 2.79 and 2.81. I read on the forum that version 2.80 of blender doesn’t work so I installed the 2.7 addon for 2.79 and 2.8 addon for 2.81. I set the proper port number, and clicked “Start!” and, for some reason, it closes the application every time the button “start!” is pressed.

Additionally, whether the “automatically send when blend file changes” button is pressed or not, whenever “Connect” is pressed, I get a: “Report: Error Connection Failed”


I don’t know maybe I have the wrong copy of OsciStudio, but as a college student I can’t afford to be spending another $55 on this. I really love this software and want to use it, so I hope that someone could help me with the matter!

Any help would be greatly appreciated!

p.s. I have more photos but only new users can post more than 1 photo lol



let’s see if we can figure it out :slight_smile:

do you know a little bit how to use the terminal? if yes, these are the steps to try:

  1. Open cmd or a windows terminal
    cd to the app folder of OsciStudio. In my case i run the command
    cd C:\Users\Hansi\Downloads\OsciStudio_0.6.0.38_pre3_win\app

    it’s best you go to that folder in explorer, click in the address bar and copy the path.
    then open a cmd, type "cd ", paste the path and hit enter.

  2. start oscistudio by running
    OsciStudio.exe >log.txt 2>&1

  3. the terminal will hide now, this is fine :slight_smile: press “start” and i guess you get your typical crash

  4. there should be a file “log.txt” next to OsciStudio.exe now. please send this to me!

if you need more detailed instructions let me know.

all the other behaviors you describe make sense, you cannot connect from blender before oscistudio is started. so let’s figure out why it crashes, then the rest should start working too.


I followed your steps and everything worked out! Thank god lol.

Thanks for the help!