Oscilloscope & oscistudio show ringing on corners of shapes from blender


#1

OsciStudio Version: 6.0.38pre2
Operating System: Windows 10
Blender 2.82a

Hello,
I’m new to oscistudio but have done a fair bit of oscilloscope music experimenting with max/msp before. I’m trying to put together a music video which I hope to make mostly 2d text animated on the oscilloscope, and I’m modeling it in blender so oscistudio can animate and turn it into sound. However I’m finding that my setup produces a pretty drastic ringing on the corners of objects, presumably the first and last vertices of shapes.

I know it generally better to separate complex shapes and display them sequentially rather than simultaneously, but looking at Hansi’s “stranger things” demo, I’m unable to reproduce the fidelity exhibited in his video on youtube. I’m running at 96khz and loading the demo directly from the program folder. Screenshot below demonstrates what I mean.

Is this just a matter of getting an interface that runs at 192khz or is there something I’m missing in the software setup? I can certainly cull some vertices and manually connect letter glyphs, but I’m hoping to be able to complete a bunch of animations in a sane amount of time and reduce manual letter editing, so any feedback is appreciated!


#2

In the same situation! I have been optimising my animations by reducing vertices but the fidelity isn’t where I want it to be. Slowing down the freq. makes things clearer at the cost of not seeing the entire image at once.


#3

I’m not certain, but I’m pretty sure Hansi records everything at 192k. I also use 96k, so I feel your pain!

You can also use some of Oscistudio’s built in FX to help with this. Try putting some Trace onto the image (~ 0.75 - .95 length, with an LFO on ‘From’) and/or putting a Dash effect onto the image. Both of these can buy you some more headroom automatically, without undermining the overall clarity of the image.


#4

Basically what everyone has said here, but I would highly recommend getting an interface that allows for 192k. Your images will much much crisper. The other option would to just start using lower frequencies and fewer vertices, in addition to what zippy731 suggested.


#5

hi!

i often use 96k as well, but this one was exported at 192k.

you can try this:

  1. bounce a wav to get a 192k file (cmd+b on mac, ctrl+b on windows)
  2. bring it into the oscilloscope application and export an image sequence (the E key)
  3. combine the video with the original sound. for this i use the commandline version of ffmpeg and this command: ffmpeg -framerate 60 -pattern_type glob -i "*.png" -i /Users/hansi/Documents/oscistudio-2020-02-08-bounce.wav -c:v libx264 -pix_fmt yuv420p -r 60 -b:a 384k ../cube_rot.mp4

#6

ps. if you dislike the ringing, then you can also look into the “digital” simulation option which disables the ringing completely. you find it in the top right together with all the other preview settings.

if you play it on a real scope, there will always be some ringing from the audio interface though.


#7

@kritzikratzi - you mention a ‘digital’ option for addressing ringing.

Is that in oscistudio or oscilloscope app? I don’t see it in either place, but I suspect I’m working from an older version…