Oscistudio and Blender 2.8?


Hansi answered over in the subreddit:

<<just tried it out, will have to make a few changes. i can back here when it’s done.>>



can you give this a shot?



I’ll download it and try it out. Would you expect this to also still work with blender 2.79? Or is it only meant for 2.8?


only 2.8, i don’t think i want to maintain backwards compat with the old blender unless there is a good reason.

blender themselves seem to really push 2.8


gotcha. will let u know what I find out


OK, quick first impressions:
I’m using Blender 2.8 64bit on windows 7 Pro 64bit, using your new .py file and connecting to oscistudio v5.5 64bit.

1_ good: immediately connected to oscistudio, and oscistudio immediately saw the simple mesh I created. It seemed snappy w.r.t. reaction to blender. It also reflected simple edits, translations, scale, rotation, etc.
2_ bad: oscistudio did NOT preview the blender animation timeline while scrubbing in blender. I did a simple animation changing translation and rotation of the mesh, but the objects did not move in oscistudio.
3_good: oscistudio DID see the rotation/translation animation when I used the “send animation” button in blender.
4_bad: oscistudio did NOT honor hide/show visibility toggle. All blender objects were visible in oscistudio, even if they were invisible in blender.
5_good: oscistudio seemed to handle blender modifiers and high vertex counts correctly, for the few I tested.

This is not comprehensive, just about :20 of testing simple things.

SO>> not quite done, but not fully broken either. :smiley:



thanks for testing! think i fixed those problems. can you try again?

[download removed, see Blender 2.82 and Oscistudio - connection issues ]

Can't install OsciStudio client in Blender 2.81a

It seems with Blender 2.8 and Win10 that ‘Send Animation’ doesn’t work…


can you describe a bit more what you did? it worked on my computer :slight_smile:
a screen video would be best.


Hi Kritzikratzi,
Sorry for my late reply. Anim export seems to be working fine with basic primitives, e. g. cube, sphere, monkey. More complex animations (rigged character, reduced to 2000 vertices) cause no problems in 2.79, but won’t work in 2.8. I tried to isolate what causes 2.8 to behave like this, but I had no luck finding the issue. It’s not the length of the animation (I try to stay between 100 - 250 frames) or the complexity of geometry. When I hit ‘send animation’, it says ‘sequence started’ and then it just stops and won’t go through each frame. Neither Blender nor Osci studio crash, it’s just that the animation won’t get exported.

Another thing (maybe for a new thread): When I export a .wav from OsciStudio and load it into Oscilloscope, the lines lose some of their vibrancy. Is there a way to maintain the look exactly as in OsciStudio? My only work around for now is to do a screen capture directly from OsciStudio, as suggested in another thread.

Besten Dank!


I’ve been racking my brain trying to get Blender 2.8 working with Oscistudio for the first time. I’m using (I believe) the most updated oscistudio.py (1.4). After installing the addon, I open and start Oscistudio, go to Oscistudio Global Settings and hit connect. I get Error: Connection failed. I tried changing the port number, same result. Started both programs as administrator, same result. The only way I have found to progress is to turn off “Automatically send when blend file changes”. I get a “Connected!” message, but no output in Oscistudio.

I am on a Windows 10 64bit machine.


Hm. I’m still using oscistudio with blender 2.79, but have tested with 2.8 and it worked OK for me (limited test.)

One thought: Are you using a simple blend file to initially test the connection (like the default cube or something like that?) If your blend is too complex, oscistudio doesn’t like it…

Also, if you can share a screen cap of the steps you’re taking and what’s going on, might be able to better help.


Sure. I’ll include some screencaps

I start with the basic cube in blender 2.8

Under preferences I have installed the most recent version of the oscistudio plugin.

When this box is not ticked, I can successfully connect, but there is no output in Oscistudio

When the box is ticked, I get this error.

Regardless of what setting I use, nothing transfers over to Oscistudio. I have noticed one thing: When the box is unticked and I successfully connect, if I close Blender, Oscistudio will automatically close.


I haven’t had a chance to fully test your setup, but just looking through these images, I note you’re using oscistudio 6.0.

I tested oscistudio 5.5 with 2.8, and it worked for me (with some limitations.) 6.0 never worked for me because my current graphics card can’t handle the graphics upgrades.

I haven’t had a chance to get back and re-test using hansi’s updated connector, but maybe try to grab a copy of 5.5 and see if that helps your situation with blender 2.8…


Just downloaded oscistudio 5.5 to check and, no, it did not work. Same issues as before.


Issue resolved! Blender 2.8 is not compatable with Oscistudio 0.6, but Blender 2.81 is! I can see the output in Oscistudio right away and it updates as I change the scene. Looking forward to learning more, and thanks for the help troubleshooting.


Blender 2.81 and Oscistudio 0.6 work well together, but still I am facing the issue Enz presented.
Sending the animation won’t work, I have tested with a simple position animation on a cube:

Log: “Sequence Started”
Viewport and Oscistudio show step by step the animation

Once done blender returns to the first timeline frame, Oscistudio too, the Time parameter doesn’t works,

I also noticed the “Automatically send when blend file changes” doesn’t makes any difference, I am just afraid the plugin is overriding the animation with the realtime data.

With more complex animation (a ton of parents, modifiers and even animation nodes) I couldn’t see the animation progress, so I bet it wouldn’t anyways work.

Thanks for the support!



@Pivetta in general: yes, checking “automatically send when blend file changes” should override the animation with realtime data, that is absolutely expected.
is it easy for you to take a screencapture (or recording with your phone) of the “time” parameter not working and start a new topic?


Not sure if this has been discussed elsewhere but is there any way to send meshes to Oscistudio as they’re seen through a Blender camera? Right now, meshes seem to come in from a top-down view.
Being able to animate and cull meshes based on a camera’s viewing frustum would drastically increase control over sound and sequencing.


Blender 2.82 and Oscistudio - connection issues

Oscistudio doesn’t have built-in tools for that.

However, you can do it in blender, so what Oscistudio “sees” is more useful.

If you use a plugin in Blender called “Animation Nodes”, you can get much finer control over many aspects of your blender project, including a node that only shows what a specific camera sees.

Learning Animation Nodes is a little involved, but is worth IMHO.

I’ve got a couple of tutorials on the topic of hiding backfaces, and the blender examples I’ve included utilize the “Point In Camera Frustrum” node in animation nodes. It’s a bit involved, but worth it to get clear visuals.

And also, here’s a write-up I did on the subject in Blender Stack Exchange:

Here’s a link to Animation Nodes:

BTW, all of my examples are using Blender 2.79, and I haven’t tested it all in Blender 2.8x yet.