Testing the oscilloscope linux version



If you have linux and a tiny bit of time, please test this:

Oscilloscope-2020-06-26-linux64.zip (2.8 MB)

… does it even start?

I have a disconnect between how amazing the visuals look in oscistudio vs rendered






No luck on my end. Though today I did get it to build from source successfully (but I had to deviate from the instructions a fair bit). I’m thinking of opening a pull request with a more reliable linux build process.



thanks for looking into it a bit! can you explain a bit what you had to change?

maybe it was just misunderstandings, you shouldn’t have to change anything really…


After installing a few dependencies on my work computer, this ran flawlessly for me.

At home, I tried 2 different machines and got this:
Illegal instruction (core dumped)

Not sure what’s up with that. Maybe this weekend I will do the git clone thing mentioned in the readme. I leeched that at work but it looked like it might take a few steps to get it to compile on that machine…

I forget, but I probably have around 10 different Linux machines at home to experiment with…

Thanks for putting this together. :slight_smile:



@rrolison68 have you built an openframeworks project before?

you need version 0.10.1 from here: https://openframeworks.cc/versions/v0.10.1/

follow setup instructions from here: https://openframeworks.cc/setup/linux-install/

then clone the repo into of_0.10.1/apps/myApps/oscilloscope

about the prebuilt binaries you tested… (thx for testing btw!)

which dependencies did you need? anything other than ffmpeg?


ps. i think “illegal instruction” might be exactly what it says on the can: maybe avx512 or smtgh like that was enabled and is not available on your other computers. different cpus maybe?


The computers that it did not work on ARE old. They are old enough that even Blender 2.8 won’t run because the GPU isn’t good enough. I have to use Blender 2.7 on those…

The computer at work has an Intel® Core™ i5-6200U CPU @ 2.30GHz (No extra GPU)
Ubuntu Server 20 was installed, and then KDE Plasma was piled on top as my display manager.

I used Synaptic to install these dependencies:

I have never built an openframeworks project before, and I am quite curious, so I will follow the above steps and report back.

The CPU’s of the 2 units that gave me the error were:
Intel® Core™ i7-2760QM CPU @ 2.40GHz
Intel® Core™2 Duo CPU T9600 @ 2.80GHz

Thanks again for creating such cool things. :slight_smile:



I took a vacation day today, so I am home playing around more… I have several, identical, but VERY low end laptops here, but they are fairly new. I ran the precompiled binary on one of these. I had to install the same list of dependencies, which is logical because these Ubuntu deployments are identical… It ran flawlessly…

The CPU on this particular unit is a:

I’m starting to believe that old CPU’s are lacking instructions or something that the code needs.



yep, that’s what i meant with avx (could also be sse 4 or smtgh like that)… need to check the compile flags, but i’m away from my linux computer at the moment


I am currently installing the Open Frameworks stuff on one of these cheap computers at home today. I will report back what happens with that. I am writing down a detailed step by step of what I am doing… When I get that set up properly, it would be neat to know how to make adjustments to make this work on antique computers if possible…

Interesting side note, when I use Microsoft’s Remote Desktop to access the Ubuntu machine, Oscilloscope runs fine, even in full screen. After that, I used (from a Ubuntu unit) ssh -X remotecomputer to log in and Oscilloscope runs fine that way too, including full screen. I only mention this, because many applications do NOT like rendering their image to a remote display, but this code doesn’t seem to care… :slight_smile:



install procedure: neat! °.°

fullscreen: i think that’s because it’s not really fullscreen (also called “exclusive fullscreen”), it’s really just a giant window with no title bar.


It looks like, while Open Frameworks is installing dependencies, it’s adding the ones I manually installed. So… I suspect, and will verify later, that if someone installs Open Frameworks properly, they do not need to install the dependencies I installed manually…



i see.

well, it’s still good to know which dependencies are needed to install the binaries only. i was told someone i know knows someone who might be able to make a debian/ubuntu package (if you’re knowledgable at that… please go ahead, i’m happy for any help ^^)


Sadly, I am not expert at anything, but I will certainly look into creating a standalone Debian/Ubuntu package installer after I succeed at building the code properly. I have had way too much fun with Oscistudio since I bought it, so, if there is anything I could do to help, I would be thrilled.

I am doing this work on two machines at the same time at the moment, so I will learn more shortly…

Not appropriate for all audiences, but this is probably one of my favortite things I did with your code. :slight_smile:



Now attempting to “make”… I have stalled. It’s possible I am not moving the libs folder where it needs to be… I’ll work on figuring out the answer to that now…

The update though, is, after installing Open Frameworks, there is only one missing dependency to get the precompiled binary to run. That’s added by merely doing the following:

sudo apt-get install libboost-filesystem1.67.0 -y